> EtherChannel Cisco - GNS3 - FAQs Tech
News Update
Loading...

Minggu, 13 September 2020

EtherChannel Cisco - GNS3


Mungkin dari kalian pernah mendengar yang namanya Etherchannel. Etherchannel merupakan teknik penggabungan beberapa jalur fisik menjadi 1 jalur logik dan bisa dibuat dengan group port (port-channel). Etherchannel ini berkaitan erat dengan Load Balance, dimana ini bisa meningkatkan throughput, memperkecil latency, dan menghidari overload pada saat trafik data berjalan.
Yang menarik dari Etherchannel ini, jika salah satu port dalam port-channel rusak / mati, port yang lain tetap mengirimkan trafik data (Faul Tolerance). Speed data juga di gabungkan dari setiap jalur port fisik. Contoh: 3 jalur port fisik masing-masing memiliki 100MBps, jika di gabungkan dengan satu jalur logikal, maka speed akan meningkat menjadi 300MBps.
Pada artikel ini, mimin akan membahas cara implementasi Etherchannel pada GNS3. bisa saja menggunakan Packet Tracer, namun ada beberapa langkah yang berbeda dengan GNS3.

Tutorial Etherchannel pada GNS3

Topologi


Topologi

untuk Device virtual saya menggunakan:
  • 3 Switch Cisco IOSvL2 15.2(20170321:233949)
  • 3 Client Windows 10 Lite
Dengan 3 VLAN ID. 10 , 20 , dan 20.
Protocol negosiasi yang digunakan pada Etherchannel nanti adalah protocol pagp

Untuk tambahan, pada switch saya menggunakan server lokal tidak menggunakan GNS3-VM sebagai servernya si Switch. (dikarnakan, semakin banyak port switch yang dipakai, maka penggunaan RAM semakin banyak juga.)


Langkah-langkah Praktikum

1. Membuat SVI dan memberi keanggotaaan VLAN pada setiap Switch

Buatlah VLAN dengan ID baru, caranya sama seperti artikel sebelumnya yaitu, Inter-VLAN pada GNS3, lalu masukkan akses port pada VLAN yang dibuat. Kemudian buat juga SVI Interface vlan pada switch, lakukan show vlan brief, untuk pengechekan, apakah vlan sudah sesuai apa tidak.

Konfigurasi Switch-1
Switch-1#configure terminal
Switch-1(config)#vlan 10
Switch-1(config-vlan)#exit
Switch-1(config)#interface vlan 10
Switch-1(config-if)#ip address 10.10.10.1 255.255.255.0
Switch-1(config-if)#no shutdown
Switch-1(config-if)#exit
Switch-1(config)#interface gigabitethernet 1/0
Switch-1(config-if)#switchport access vlan 10

Konfigurasi Switch-2
Switch-2#configure terminal
Switch-2(config)#vlan 20
Switch-2(config-vlan)#exit
Switch-2(config)#interface vlan 20
Switch-2(config-if)#ip address 20.20.20.1 255.255.255.0
Switch-1(config-if)#no shutdown
Switch-2(config-if)#exit
Switch-2(config)#interface gigabitethernet 1/0
Switch-2(config-if)#switchport access vlan 20

Konfigurasi Switch-3
Switch-3#configure terminal
Switch-3(config)#vlan 30
Switch-3(config-vlan)#exit
Switch-3(config)#interface vlan 30
Switch-3(config-if)#ip address 30.30.30.1 255.255.255.0
Switch-1(config-if)#no shutdown
Switch-3(config-if)#exit
Switch-3(config)#interface gigabitethernet 1/0
Switch-3(config-if)#switchport access vlan 30


2. Pengaktifan Etherchannel pada setiap Switch

pada langkah ini kita akan memulai konfigurasi etherchannel, bisa kita liat Po1 dari topologi diatas adalah satu jalur logikal yang mnghubungkan Switch-1 dan Switch-2, salah satu ujung node akan kita beri mode desirable atau auto, begitu juga dengan Po2 dan Po3. 
Bagi yang belum tau, nomor port channel bisa diketahui ketika membuat channel-group. Contoh: #channel-group 1 mode <...> berarti port-channel nya adalah 1.
Ohh iya, nanti di interface port-channel kita akan memberikan ip address agak bisa melakukan fungsi routing nantinya. Tetapi pada dasarnya Switch tidak mengenal ip address dan hanya bekerja di Layer 2. maka dari itu kita akan meningkatkan 1 level ke Layer 3. Proses Up dari Layer 2 ke Layer 3 hanya membutuhkan perintah no switchport pada interface fisik dan tidak bisa dilakukan pada interface virtual. (Port-channel merupakan interface virtual, jadi tidak bisa langsung diup ke Layer 3)

Contoh:
Switch-1(config)#interface <type_dan_nomor_interface>
Switch-1(config-if)#no switchport

Konfigurasi Switch-1
Switch-1(config)#interface range gigabitethernet 0/0-3
Switch-1(config-if-range)#no switchport

Konfigurasi Switch-2
Switch-2(config)#interface range gigabitethernet 0/0-3
Switch-2(config-if-range)#no switchport

Konfigurasi Switch-3
Switch-3(config)#interface range gigabitethernet 0/0-3
Switch-3(config-if-range)#no switchport

Setelah itu kita masuk konfigurasi Etherchannel, kita akan konfigurasi mulai dari Po1, dimana interface gi0/0 dan 0/1 di Switch-1 terhubung dengan gi0/0dan gi0/1. di Switch-1 kita akan beri mode auto sedangkan Switch-2 kita beri mode desirable.

Port-Channel 1
Konfigurasi Switch-1
Switch-1(config)#interface range gigabitethernet 0/0-1
Switch-1(config-if-range)#channel-protocol pagp
Switch-1(config-if-range)#channel-group 1 mode auto

Konfigurasi Switch-2
Switch-2(config)#interface range gigabitethernet 0/0-1
Switch-2(config-if-range)#channel-protocol pagp
Switch-2(config-if-range)#channel-group 1 mode desirable


Etherchannel Summary

Jika sudah, lakukan pengechekan Etherchannel dengan perintah show etherchannel summary. kalian akan melihat Port-Channel 1 yang memilik Kode (RU). dimana [R] yang berarti switch bekerja di Layer 3. Kemudian lanjutkan konfigurasi ke Po2 dan Po3

Port-Channel 2
Konfigurasi Switch-2
Switch-2(config)#interface range gigabitethernet 0/2-3
Switch-2(config-if-range)#channel-protocol pagp
Switch-2(config-if-range)#channel-group 2 mode auto

Konfigurasi Switch-3
Switch-3(config)#interface range gigabitethernet 0/2-3
Switch-3(config-if-range)#channel-protocol pagp
Switch-3(config-if-range)#channel-group 2 mode desirable

Port-Channel 3
Konfigurasi Switch-1
Switch-1(config)#interface range gigabitethernet 0/2-3
Switch-1(config-if-range)#channel-protocol pagp
Switch-1(config-if-range)#channel-group 3 mode desirable

Konfigurasi Switch-3
Switch-3(config)#interface range gigabitethernet 0/0-1
Switch-3(config-if-range)#channel-protocol pagp
Switch-3(config-if-range)#channel-group 3 mode auto

3. Membuat IP Address pada Interface Port-Channel

Untuk memberikan IP address pada port-channel sama seperti interbiasanya, hanya saya interface virtual ini tidak membutuhkan perintah no shutdown karna port fisiknya sudah aktif, berbeda dengan interface vlan yang membutuh perintah untuk mengaktifkan interface virtual tersebut.

Port-Channel 1
Konfigurasi Switch-1
Switch-1(config)#interface port-channel 1
Switch-1(config-if)#ip address 1.1.1.1 255.255.255.252

Konfigurasi Switch-2
Switch-2(config)#interface port-channel 2
Switch-2(config-if)#ip address 1.1.1.2 255.255.255.252

Port-Channel 2
Konfigurasi Switch-2
Switch-2(config)#interface port-channel 2
Switch-2(config-if)#ip address 2.2.2.1 255.255.255.252

Konfigurasi Switch-3
Switch-3(config)#interface port-channel 2
Switch-3(config-if)#ip address 2.2.2.2 255.255.255.252

Port-Channel 3
Konfigurasi Switch-1
Switch-1(config)#interface port-channel 3
Switch-1(config-if)#ip address 3.3.3.1 255.255.255.252

Konfigurasi Switch-3
Switch-3(config)#interface port-channel 3
Switch-3(config-if)#ip address 3.3.3.2 255.255.255.252


4. Melakukan Routing pada Switch di Layer 3

Disini kita tidak menggunakan trunking pada port switch dan diawal kita sudah membuat SVI untuk di routing dari setiap switch. Saya menggunakan routing protokol ospf, lalu agar Switch bisa melakukan routing kita perlu memberi perintah ip routing agak fungsi routing itu aktif. Untuk routing saya menggunakan OSPF, kalian juga bisa menggunakan routing dinamis lainnya atau static

Konfigurasi Switch-1
Switch-1(config)#ip routing
Switch-1(config)router ospf 5
Switch-1(config-router) network 10.10.10.0 0.0.0.255 area 0
Switch-1(config-router) network 1.1.1.0 0.0.0.3 area 0
Switch-1(config-router) network 3.3.3.0 0.0.0.3 area 0

Konfigurasi Switch-2
Switch-2(config)#ip routing
Switch-2(config)router ospf 5
Switch-2(config-router) network 20.20.20.0 0.0.0.255 area 0
Switch-2(config-router) network 1.1.1.0 0.0.0.3 area 0
Switch-2(config-router) network 2.2.2.0 0.0.0.3 area 0

Konfigurasi Switch-3
Switch-3(config)#ip routing
Switch-3(config)router ospf 5
Switch-3(config-router) network 30.30.30.0 0.0.0.255 area 0
Switch-3(config-router) network 2.2.2.0 0.0.0.3 area 0
Switch-3(config-router) network 3.3.3.0 0.0.0.3 area 0

IP Route

Jangan lupa check informasi route apakah sudah benar apa belum dengan perintah show ip route

Loading Done

Jika kalian melihat notif diatas "from LOADING to FULL, Loading Done" itu tandanya Etherchannel sukses dan sudah terkonesi


5. Test Koneksi

Ini adalah tahap terakhir untuk uji koneksi. Jangan lupa untuk memberi ip address pada client agak bisa berkomunikasi.

Client-1

Uji Koneksi dari Client-1 ke Client-2

Client-2

Uji Koneksi dari Client-2 ke Client-3

Client-3

Uji Koneksi dari Client 3 ke CLient 1. and Done :D

Sekian artikel dari saya, semoga bermanfaat. Peace xD

Share with your friends

Give us your opinion

Silahkan berkomentar dengan bijak :v

Notifikasi
#Stay_Safe yaa :)
Done