> Inter-VLAN Routing dengan Sub-Interface - GNS3 - FAQs Tech
News Update
Loading...

Rabu, 12 Agustus 2020

Inter-VLAN Routing dengan Sub-Interface - GNS3


Sesuai dengan judul, melakukan routing dengan sub-interface, sebelum lanjut kepraktikum nya. Saya akan menjelaskan apa sih Sub-Interface itu? Sub-Interface ialah interface nonfisik atau bisa dikatakan interface virtual.

sub-interface berguna untuk memudahkan kita dalam memanajemen client dengan segmen network yang berbeda-beda. Ada 4 virtual interface, yaitu: 
  • Loopback Interfaces
  • Null Interfaces
  • Subinterfaces
  • Tunnel Interfaces


Inter-VLAN Routing Cisco dengan Sub-Interface


Topologi


Topologi

Pada topologi saya menginplementasikannya pada GNS3 dengan: 
  • 2 Client - Windows 10
  • 1 Switch - Cisco IOU L2
  • 1 Router -  Cisco 7200
Dan dua ID VLAN, 5 dan 15

Langkah-langkah Praktikum:

1. Membuat VLAN pada Switch

Disini saya menggunakan VLAN 5 dengan nama "Y" dan VLAN 15 dengan nama "Z", untuk nama bisa disesuaikan dengan keinginan kalian.

Switch#configure terminal
Switch(config)#vlan 5
Switch(config-vlan)# Name X
Switch(config-vlan)#vlan 10
Switch(config-vlan)#name Y
Switch(config-vlan)#vlan 15
Switch(config-vlan)#name Z

2. Menambahkan port access pada VLAN 

Jika sudah, ubah akses default vlan pada switch yang terhubung pada client ke VLAN yang sudah ditentukan
Switch#configure terminal
Switch(config)#Switch(config)#interface ethernet0/1
Switch(config-if)#switchport access vlan 5
Switch(config)#interface ethernet0/2
Switch(config-if)#switchport access vlan 15

3. Membuat Sub-Interface dan Trunking pada Router

pada pembuatan Sub-interface sama seperti jalur logic yang akan dibagi-bagi menjadi beberapa jalur logic walapun hanya dapat diliat secara virtual dan untuk memudahkan kita dalam memanajemen, penomoran sub-interface disesuaikan dengan VLAN ID. 

setelah sub-interface, kemudian ada juga pembuatan jalur trunking. Kita mendefinisikan protokol enkapsulasi yang nanti digunakan untuk jalur trunking. Ada 2 pilihan protokol trunking yang bisa digunakan, yaitu ISL dan IEEE 802.1Q. Disini kita akan menggunakan protocol IEEE 802.1Q karna sifatnya Open.
#interface ethernet 0/0.<VLAN_ID>
#encapsulation dot1q <VLAN_ID> menjadi
#interface ethernet 0/0.5
#encapsulation dot1q 5
Hasil Konfigurasi
Router#configure terminal
Router(config)#interface ethernet 0/0.15
Router(config-if)#encasulation dot1q 15
Router(config-if)#ip address 192.168.5.1 255.255.255.0
outer(config-if)#exit
Router(config)#interface ethernet 0/0.15
Router(config-if)#encasulation dot1q 15
Router(config-if)#ip address 192.168.15.1 255.255.255.0

dan jangan lupa untuk mengaktifkan interface fisiknya, karna jika interface fisik tidak diaktifkan maka sub-interface juga tidak akan aktif.

Router(config)#interface fastethernet 0/0
Router(config-if)#no shutdown

4. Membuat jalur Trunking pada Switch

Dikarnakan jalur trunking baru hanya dilakukan oleh router "dot1q 5" dan "dot1 15" artinya router sudah membuat jalur trafik data untuk VLAN tersebut, kita juga harus melakukan trunking pada switch.
Switch(config)#interface ethernet 0/0
Switch(config-if)#switchport mode trunk

Kemudian check status port, jika Operational Mode sudah menjadi Trunk berarti kita sudah selesai melakukan konfigurasi pada switch dan router.


5. Uji Koneksi

Jangan lupa sebelumnya kalian sudah mengkonfigurasi IP disisi client xD


Disini saya berhasil melakukan ping dari Client VLAN 5 ke VLAN 15 dan begitu juga sebaliknya.

Sekian artikel dari saya, semoga bermanfaat. Peace xD

Share with your friends

Give us your opinion

Silahkan berkomentar dengan bijak :v

Notifikasi
#Stay_Safe yaa :)
Done